Blame 4.4 available!!!!!!

Blame! IconBlame! 4.4 is now available in the App Store with the following features:

-iPhone 5s support.

 

Posted in News